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Squash and Stretch: Lesson 1

Understanding the Principle of Squash and Stretch
Squash and Stretch is a commonly used animation principle applied to moving shapes or characters. It is seen when an object’s shape is 
changed or exaggerated to create more fluid, realistic-looking motion. Squash and Stretch also serves to give the viewer an impression of what 
the object is made of. For example, more squashing and stretching looks rubbery, organic and flexible (like a living being); less squashing and 
stretching appears hard and inflexible (like a bowling ball).

One general rule with Squash and Stretch is to change an object’s shape without changing its volume. This allows the animator to add 
flexibility to the animation and allows a character to move to more extreme positions.

Related Project Files
The following related project files are located in the ASCurriculum-Lesson1.zip file that accompanies this course:

t� Tutorial 1.1.anme - A final version of the project that you will complete in this lesson.

t� Tutorial 1.1.mov - A final render of the project that you will complete in this lesson.

t� Tutorial 1.1 How To.mov - A step-by-step video tutorial of the project that you will complete in this lesson.

Tools Used
t� Draw Shape tool, Rotate Layer tool, Scale Layer tool, Translate Layer tool

Tutorial 1: Overview
In this lesson, we’ll create a bouncing ball. You’ll see how 
the ball squashes when it hits the ground and stretches as 
it bounces in the air. Keep in mind that when animating a 
ball, the weight of the ball is important, since it defines how 
high a ball will bounce and how much it will squash. Here is 
what you’ll complete in this lesson:

t� First, set the main key poses: where the ball will start, 
where it collides with the ground, and where it will end.

t� Next, add in breakdowns to shape the arcs and define the 
path of the bouncing ball.

t� Thirdly, add squashes and stretches to further enhance the 
way the ball responds to collisions and going up in the air.

t� Finally, add rotations to correspond with the angles of the 
arcs in the path.
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Tutorial 1: Step-by-Step
Now that we have the main positions set, you’ll want to preview your work. To do that, reset the Frame Counter to 0 and press the PLAY 
button on the timeline indicator. You’ll notice that the ball is travelling along paths that are fairly straight. In reality, a ball bounces along paths 
that look more like arcs, so we’ll refine those next. 

Step 1: Start at Frame 0
To get started, go to File > New to 
open a new Anime Studio document 
(.anme file).

Once you open your document, make 
sure you’re on Frame 0 in the timeline. 
You can click the numbers in the 
timeline to move from frame to frame.

Save your file by going to File > Save  
and naming it Lesson1_YourLastName. 
It’s important to save often to avoid 
losing your work.

The bottom half of this screenshot 
displays the timeline in Anime Studio. 

Step 2: Set Tool Options

 When you use the Draw 
Shape tool, you’ll also find it 
convenient to have the Auto 
Fill option checked. This option 
automatically fills a closed shape 
with color as you create it.

Select the Draw Shape tool from 
the Draw section of the Tools 
panel. Next, make sure you have 
the Oval shape selected from the 
Options bar. 

For further information on the Draw 
Shape tool, refer to the Anime 
Studio Debut Users Manual pdf. 

You can access the Users 
Manual from within the Anime 
Studio application by going to 
Help > Help.

The arrow in this screenshot points 
to the blue rectangle that indicates 
the visible region of the project. Only 
objects that are within this rectangle 
will appear in your final animation.

Step 3: Choose a Fill Color
The default color is set to white 
when you first start Anime Studio. 
You can select a different fill color 
and/or stroke color from the Style 
window at the right side of the 
interface. Here we’ll change the color 
to green. Double-click the Fill field to 
select a green shade of your choice.

For further information on the Style 
window, refer to the Anime Studio 
Debut Users Manual. 
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Step 4: Draw a Ball

 With the Draw Shape tool 
selected, press the Shift key while 
you drag a circle shape in the center 
of the stage. 

The Shift key constrains the shape to 
a perfect circle. The Alt key centers 
the circle at the point you first clicked.

For further information on the 
Freehand tool, refer to the Anime 
Studio Debut Users Manual. 

Step 5: Drag the Ball 
Off the Stage

 Now select the Translate 
Layer tool from the Layers section 
of the toolbox. Drag the ball to the 
upper left corner of the screen so 
that it’s off the stage.

We don’t want the ball to move until 
it reaches Frame 5. To accomplish 
this, position the timeline indicator 
at Frame 5 to make it the current 
frame. Then right-click on the timeline 
and choose Add Keyframe. 

You cannot set the first keyframe in 
the timeline unless you have started 
animating first. There are two ways 
to set the first keyframe without 
moving the object or animating it:

1: Click and drag the cursor in the 
timeline to Frame 5. Then select the 
Translate Layer tool and click on the 
Reset button at the top.

2: Move to frame 5. Then using the 
Translate Layer tool, click anywhere 
on the screen (without moving the 
object), and it will add a keyframe at 
Frame 5.

For further information on the 
Translate Layer tool, refer to the 
Anime Studio Debut Users Manual.

Do not worry about adding rotation 
and scale just yet. It’s important to 
get the general motion down first.
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Step 6: Set Main Positions 

 Now we’ll set the main 
positions for the bouncing ball. It 
will bounce on the floor twice as it 
goes from the left side of the screen 
to the right. First, move the timeline 
indicator to Frame 30. 

The timeline indicator is the red 
line with the inverted triangle that 
is on your currently selected frame. 
To move the timeline indicator, you 
can either drag the inverted triangle 
to the new position (Frame 30) or 
just click once on the number 30 on 
the timeline. You can also type the 
number of the frame into the frame 
counter (FRAME XX of 240) and 
hit the enter key to advance to that 
frame. To be sure that you are in 
the proper frame, look at the Frame 
Counter. It should now read Frame 
30 of 240.

Use the Translate Layer tool to 
drag the ball to the bottom of the 
stage, positioning it about one-
quarter of the way into the scene. 

Next, click to select Frame 60 and 
move the ball to the top of the stage 
close to the center.

Generally an appropriate time 
amount for a ball to bounce 1 or 
2 times is 120 frames. However, 
depending on the volume, speed, 
rubber consistency and weight of  
the ball you’re animating,  
you may desire more or  
less frames.

Note: When you click on  
a frame and then move  
an object in the scene,  
a keyframe will automatically be 
added.

Step 7: Set Main Positions 
(continued)

 For the second bounce to 
the floor, click to select Frame 90, 
and move the ball to the lower-right 
area of the scene, as shown in the 
screenshot to the right. Finally, click to 
select Frame 120, and move the ball 
to the top again, this time positioning 
it outside to the right of the stage.

Now let’s set the maximum number 
of frames for this project. This will 
keep the ball bouncing only between 
frames 0 and 120. To do that, reset 
the Frame Counter to 0 and type the 
number 120 into the second box. 
Press ENTER. You should now see 
that the blue bar on the timeline 
extends only to Frame 120. 
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Step 8: Shape the Arcs
Now that we have the main positions 
set, you’ll want to preview your 
work. To do that, reset the Frame 
Counter to 0 and press the PLAY 
button on the timeline indicator. 
You’ll notice that the ball is travelling 
along paths that are fairly straight. 
In reality, a ball bounces along paths 
that look more like arcs, so we’ll 
refine those next. 

 Move to Frame 15 and use 
the Translate Layer tool to move 
the ball toward the right, making the 
first arc. 

At Frame 45, drag the ball 
toward the left. 

At Frame 75, drag the ball 
toward the right again. 

Finally, at Frame 105, drag the ball 
toward the left again.  
Now you have your arcs!

Step 9: Add Intermediate 
Keyframes

 To refine the shape of the 
arcs, we’ll add additional keyframes 
at about every fifth frame. We’ll 
speed through them in this tutorial, 
but they are all accomplished with 
the Translate Layer tool as you’ve 
already completed. 

Start with Frames 10, 20, and 25. 
Frame 30 is done so we’ll skip to 
35, then 40. Skip 45 (it’s done) and 
go to Frame 50, then 55. The first 
arc is complete.

Remember, to add additional 
Keyframes, position your mouse 
on the timeline (light blue bar 
with the light blue dots on it) at 
the frame you want to work with. 
Right-click (Windows) or Control-
click (Mac) and choose ADD 
KEYFRAME from the menu.
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Step 10: Intermediate 
Keyframes (continued)

 Now adjust Frames 65,  
70, 80, and frame 85. Skip to 95, 
100, 110, and 115. Now both arcs 
are complete.

Step 11:  
Stretching the Ball

 And now the subject of 
our tutorial: Squash and Stretch. In 
Anime Studio, you’ll use the Scale 
Layer tool to squash and stretch the 
ball as it bounces. 

Select the Translate Layer tool
from the Layers section of the 
toolbox. Move to Frame 15. You’ll 
perform the first stretch here. Press 
the Alt key while you move the 
bottom center-point of the bounding 
box down so the ball keeps its 
volume. 

While you scale, keep your eye on 
the Scale X and Scale Y values in 
the Properties bar. You will not see 
them change until you release the 
mouse button. Please note, you’ll 
use the same X and Y scale values 
for the three other frames where the 
ball is in mid-air. You can manually 
enter values that are easier to 
remember. Here we’ll change the X 
to .8 and Y to 1.2. 

The Rotate Layer and
Scale Layer tools are now 
built into the Translate 
Layer tool., First, choose 
the T tool and then move 
your cursor to a point on 
the bounding box. Placing 
your cursor on a bounding 
box will activate the Scale 
Layer tool, while placing 
your cursor just outside a 
corner bounding box will 
activate the Rotate Layer 
tool.

In order to use the drawing 
tools on a frame other than Frame 
zero, you have to instruct Anime 
Studio to allow it. In the menu, 
choose Anime Studio Debut 
(or Edit) > Preferences and click 
the Options tab if it is not 
displayed.  Uncheck the “Enable 
Drawing Tools Only on Frame 
0” option.
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Step 12:  
Prepare for the Squash
Just before the ball hits the ground, 
we want it to be in its round shape 
so that the stretch won’t affect the 
squash. So at Frame 25, return the X 
Scale and the Y Scale values to 1.

Step 13:  
Squashing the Ball

 At Frame 30, when the 
ball hits the ground, you want it to 
squash. We’ll keep the values similar 
to the stretch, but we’ll switch the X 
and Y around. So at Frame 30, set 
the X value for the squash to 1.2 and 
the Y value to .8.

Step 14: Complete the First 
Bounce
With one-half of the bounce done, 
you should have a pretty good idea 
of how to do the remaining ones.

NOTE: In the steps that follow, for 
Normal scale, set both X and Y to 
1. For Stretch, set X to .8 and Y to
1.2. For Squash, set X to 1.2 and Y
to 1.8.

 At Frame 35 you want the 
ball to be round. Set X and Y scale 
values to 1. 

Stretch at Frame 45.  
(X Scale = .8, Y Scale = 1.2) 

Normal scale at Frame 60. 
(X Scale = 1, Y Scale = 1) 

Note: A perfect circle has X Scale 
= 1, Y Scale = 1 coordinates and is 
also referred to as “Normal Scale” 
in this lesson. You can view and 
edit the coordinates of an object by 
selecting it with the Scale Layer 
tool.
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Step 15:  
The Second Bounce

t�  Stretch at Frame 75. 
(X Scale = .8, Y Scale = 1.2) 

t� Normal scale at Frame 85. 
(X Scale = 1, Y Scale = 1) 

t� Squash at Frame 90. 
(X Scale = 1.2, Y Scale = .8) 

Step 16: The Second Bounce 
(continued)

t�  Normal scale at Frame 95.  
(X Scale = 1, Y Scale = 1) 

t� Stretch at Frame 105. 
(X Scale = .8, Y Scale = 1.2) 

t� And at Frame 120, reset it to 
normal size.  
(X Scale = 1, Y Scale = 1)

Step 17: Rotating the 
Ball to the Path

 Click the Translate Layer 
tool to display the path beneath the 
shape on the selected frame. 

 Then switch to the Rotate 
Layer tool to tweak the rotation 
of the ball on the path. Check the 
rotation of the ball on each of the 
keyframes. 

First we’ll look at Frame 15. Notice 
how the ball appears straight up and 
down, and not aligned on the path 
at all. Use the Rotate Layer tool 
to fix that. 

The Rotate Layer and 
Scale Layer tools are now 
built into the Translate 
Layer tool., First, choose 
the T tool and then move 
your cursor to a point on 
the bounding box. Placing 
your cursor on a bounding 
box will activate the Scale 
Layer tool, while placing 
your cursor just outside a 
corner bounding box will 
activate the Rotate Layer 
tool.
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Step 18: Rotating the Ball to 
the Path (continued)

 When the Rotate Layer 
tool is selected, the path may 
disappear. Check the Show 
path box in the header to 
always see the path.

 Continue going back 
and forth between the Translate 
Layer tool and the Rotate Layer 
tool to get it right. 

Step 19:  
Finishing the Project

 The remaining 
Keyframes are done in pretty much 
the same manner. After your shapes 
are done, press the Play button to 
review your work. To review it in 
a frame-by-frame view, reset the 
counter to 0 and use the Right 
Arrow key to advance forward and 
the Left Arrow key to go back.

Continue to tweak your shapes until 
you’re happy and then save your project.

Now we will export/render our 
animation so you can view it in 
popular movie players, such as Flash® 
and QuickTime.® Go to File > Export 
Animation and enter Start Frame 
1 and End frame 120. The end 
frame represents the last frame in 
your animation. Choose your output 
format such as QuickTime Movie, 
Flash [SWF] or Windows-only AVI and 
click OK to render your animation. 

You can also upload your animation 
to YouTube™ or share it on Facebook® 
by selecting either option from the 
File menu.

Great job!




