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Anticipation: Lesson 3

Understanding the Principle of Anticipation
The Principle of Anticipation is used when preparing for an action or when taking needed movements to complete an action. Anticipation 
creates expectation and realism in your animation, helping to alert the audience that something is about to happen or has just happened. 

For example, when a baseball player hits a ball with his bat, he must first hold the bat up behind him, getting ready for the ball that will be 
thrown to him. In the same vein, the pitcher will ‘wind up’ before he throws the ball—bringing his arm behind him and taking his leg off the 
ground before he completes the pitch.

Another example would be when a character walks down the street, hears a loud sound and rapidly turns his head from left to right to 
anticipate the next action, such as a car racing down the street past the character. 

Anticipation can also be used to demonstrate weight or mass. For example, a character might bend its knees and lean back while carrying  
a heavy object.

Related Project Files
The following related project files are located in the ASCurriculum-Lesson3.zip file  that accompanies this course:

t� Jill.anme - A rigged character that you will add to your scene.

t� Jill Eyes.anme - Eyes for the character, which include switch layers that allow you to change eye expressions.

t� Tutorial 3.1.anme - A final version of the project that you will complete in this lesson.

t� Tutorial 3.1.mov - A final render of the project that you will complete in this lesson.

t� Tutorial 3.1 How To.mov - A step-by-step video tutorial of the project that you will complete in this lesson.

Tools Used
t� Pan tool, Zoom tool, Set Origin tool, Translate Layer tool, Scale Layer tool, Add Point tool, Bind Layer tool, Manipulate Bones tool

Tutorial 3: Overview
In this lesson you’ll animate a simple character that anticipates and reacts to 
a pebble falling from the sky. It consists of three levels of animation:

t� A rock will fall from the sky to the ground and bounce a few times. 
(Because rocks are solid, there won’t be any squash and stretch, and 
the bounces will be small.)

t� The character reacts to the object, demonstrating anticipation through  
the character’s eye expressions. Here the character acknowledges that  
the rock has fallen and anticipates where it will end up with different  
eye movements.

t� The final level of animation is the character picking up the rock.
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Tutorial 3: Step-by-Step

Step 1:  
Open the Character File
To begin, choose File > Open, and 
load Jill.anme from the Lesson 3.1 
files that accompany these tutorials. 

This file consists of a character that is 
already rigged for animation, which 
means that bones have already been 
set up for this character (in Layer 5), 
making it easy to animate. 

All of the bones in the character 
are arranged in a bone layer named 
Layer 5. If you want to play with the 
bones a little bit before we proceed, 
make sure you are on Frame 0. 
Click Layer 5 in the Layers window. 
Then choose the Manipulate 
Bones tool from the Bones section 
of the toolbox. You can click a bone 
with this tool and then move and 
rotate the bone to position it as you 
like. To return the character to the 
default pose, click the Select Bone 
tool in the Bone toolbox.

Step 2: Add the Eyes
The character doesn’t have any eyes, 
so you’ll add them in this tutorial. 
Choose File > Import > Anime 
Studio Object. Select Jill Eyes.anme 
from the Lesson 3.1 files.

 Use the Set Origin layer 
tool to move the origin point to the 
middle of the eyes. This allows you to 
scale the eyes more easily because the 
scaling centers around the origin point. 

 Next, select the Scale 
Layer tool and scale the eyes 
appropriately for the character. 

Save your project at this point, 
naming it Lesson3_YourLastName.

Use the Pan and Zoom workspace 
tools to zoom in closer so that you 
can see the eyes. 

Then you can use the Pan and 
Zoom tools to zoom back out to the 
whole scene. Make sure that you 
can see the area above the stage 
because you’ll draw a pebble in 
that area.

For further information on the Set 
Origin tool, refer to the Anime 
Studio Debut Users Manual. 

For further information on the 
Scale Layer tool, refer to the 
Anime Studio Debut Users Manual. 

Step 3: Choose the  
Pebble Fill Color

 Now you’ll draw the pebble. 
In the Layers window, create a new 
Vector layer, and double-click to 
rename it to Pebble. 

From the Style window, click the 
Fill color swatch to open the Color 
Picker and select a gray color for 
the pebble. To make your pebble 
look a little more three-dimensional, 
move down to the Effect drop-down 
list and select Shaded for the effect. 
Keep the default shading effects and 
choose OK to set them.

For further information on the Style 
window, refer to the Anime Studio 
Debut Users Manual. 
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Step 4: Draw the Pebble

 To draw the pebble, select 
the Add Point tool from the Draw 
toolbox. Make sure that Auto Weld 
and Auto Fill are both checked. 
Draw a small pebble above the stage 
by clicking and dragging with the 
Add Point tool. As you approach 
the end, wait until you see a green 
dot to indicate that the shape will 
automatically close. Release the 
mouse when you see the green dot. 
The pebble will automatically fill with 
the selected color and effect. 

 Use the Set Origin layer 
tool to move the origin to the 
bottom-center of the pebble.

For further information on the 
Add Point tool, refer to the Anime 
Studio Debut Users Manual.

Step 5: Copy the Pebble

 You’ll need to make a 
copy of the pebble to attach to the 
character’s hand. The reason for this 
will become clearer later. To create 
the copy, select the Pebble layer 
and click the Duplicate Layer 
button in the Layers window. 
This creates a new pebble and 
automatically names it Pebble 2. 

  Pan and Zoom, if 
necessary, so that you can see all of 
the elements in the scene. 

For further information on the Pan 
and Zoom tools, refer to the Anime 
Studio Debut Users Manual. 

Step 6: Add One Pebble to 
the Bone Group
To attach Pebble 2 to the character, 
drag the Pebble 2 layer from the 
top of the Layers window, and 
position the layer just above the  
left-hand layer of the character, 
nested inside the Layer 5 folder. 
This makes the pebble a part of the 
character’s bone hierarchy. 
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Step 7: Draw the Ground

 Now we’ll create a new 
layer for the ground. Click on the 
Pebble layer in the Layers menu to 
get back out of the Layer 5 folder. 
In the Layers window, create a 
new Vector layer and rename it 
Ground. Move the Ground layer 
to the bottom of the Layers list, 
making sure that it is not nested 
inside the Layer 5 bone list. 

 Choose a green fill color 
from the Style window, change the 
Effect to <plain>, and use the 
Draw Shape tool to draw a green 
rectangle for the ground.

Save the file and rename it as  
Jill2.anme in order to keep the 
original file intact.

Step 8: Place the Elements
Now you’ll move elements into 
place, but first we have to attach the 
eyes to the character. Drag the Eyes 
layer into Layer 5 (the bone layer), 
and position it at the very top so 
that the eyes appear above the other 
layers in the character. 

 Click on Layer 5 in the 
Layers menu to make sure that you 
are working with the entire layer. 
Then use the Translate Layer tool 
to move the character to the left side 
of the scene, and notice that the 
eyes and Pebble 2 move with her. 
Then select the Pebble layer from 
the Layers window (at the top of 
the layer list) and move it to the right 
side of the scene, keeping it above 
the stage.

For further information on the 
Translate Layer tool, refer to the 
Anime Studio Debut Users Manual.
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Step 9:  
Animate the First Pebble
To animate the pebble, move to 
Frame 6 in the timeline. 

 Use the Translate Layer 
tool to drag the Pebble layer to 
about one-third of the way down 
into the scene, moving it slightly 
toward the character. Move to 
Frame 12, and move the pebble 
close to the two-thirds mark. At 
Frame 15, place it on the ground. 

Step 10:  
Bounce the Pebble

 Now you’ll make the pebble 
bounce toward the figure, moving it 
up and down at Frames 20, 25, 30, 
35, 40, and 45. Make sure that at 
Frame 45 the pebble is placed over 
the character’s hand. 

Step 11: Position Pebble 2 
and Hide Pebble 1

 Now select the Pebble 2 
layer from the Layers window, 
and use the Translate Layer tool 
to position it directly over the first 
pebble that is on the character’s 
hand. Match up the position exactly. 

Then move to the previous frame 
(Frame 44 in this case) and set the 
X and Y positions to zero so that 
Pebble 2 does not appear in the 
stage until Frame 45. Now move 
back to Frame 45 and double-click 
the Pebble layer in the Layers 
window to make it invisible. 
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Step 12: Bind Pebble 2  
to the Character
Now you’ll attach Pebble 2 to the 
characters hand. At Frame 0,  
select the Pebble 2 layer in the 
Layers palette. 

 Then select the Bind Layer 
tool in the Bones toolbox and click 
the character’s left hand in the 
scene. The pebble is now attached to 
the character’s hand. 

For further information on the Bind 
Layer tool, refer to the Anime 
Studio Debut Users Manual.

Step 13:  
Using Switch Layers

  Zoom and pan in 
so that you can see the character’s 
eyes more clearly. Expand the 
Eyes layer in the Layers palette to 
examine the different switch layers 
that change the expression of the 
eyes. To do that, click on the Eyes 
Layer in the Layers palette. Then, 
click the arrow (to the left of the 
folder) until it is pointing down  
and the entire layer is exposed. 

After you explore, collapse the Eyes 
layer to hide the switch layers. To 
animate the eye positions in the 
scene, you’ll select some switch 
layers at various keyframes.

Switch layers are used to group 
together multiple layers, much like 
Group layers. However, Switch 
layers have an interesting twist: 
only one of their sub-layers can be 
displayed at a time.

Step 14: Animating the Eyes 

  Zoom back out so 
that you can see when the pebble 
lands on the ground so that your 
character can react to it. Move 
to Frame 15, where the pebble 
hits the ground. To change the eye 
expression, right-click on the Eyes 
layer in the Layers window and select 
Look Left. Notice that your character 
is now looking toward the pebble.
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Step 15: Animating the Eyes 
(continued)

Continue changing eye expressions 
as follows:

t� Frame 20: Worry
t� Frame 25: Look Left
t� Frame 30: Eyes Open
t� Frame 35: Shocked
t� Frame 42: Look Left

Step 16:  
Adjusting Keyframes
If you want to adjust the timing of 
the eye positions, all you need to do 
is click one of the keyframes in the 
timeline and move it toward the right 
or left. Here, we adjust the keyframes 
that originally appeared at Frames 
20-42, so that they now appear at 
Frames 32, 42, 52, 62 and 72. Now 
the eyes change expression a little 
more slowly. Play the animation to 
see how your project looks. 

Step 17:  
Picking Up the Pebble
After the pebble falls to the ground, 
you want your character to pick it up. 
In order to move the bones you have 
to select Layer 5 (the container for all 
of the bones in the character). Select 
Layer 5 from the Layers window 
and then move to Frame 49. Right-
click the timeline and choose Add 
Keyframe. This keeps the character 
in the default position until you reach 
Frame 49 in the animation.
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Step 18:  
Animating the Skeleton

 At Frame 50, use the 
Manipulate Bones tool in the 
Bones toolbox to move the position 
of the left arm. Continue on in the 
animation, making changes to the 
positions of the left hand and left 
arm at frames 54, 63, 72, 81 and 
90. Then put the pebble back on 
the ground at Frame 99. Play back 
your animation and adjust it to your 
liking. Set your end frame to 100, 
and then save the project and render  
the animation.

For further information on the 
Manipulate Bones tool, refer 
to the Anime Studio Debut Users 
Manual.


